Ubuntu Lucid Lynx und fglrx

Seit ein paar Tagen ist die neue Ubuntu-Version 10.04 „Lucid Lynx“ (Long Term Support) als final öffentlich. Und wie das so ist: bevor man sich anguckt, was daran problematisch werden könnte, installiert man das einfach mal. Das sind doch Profis, die werden schon nicht irgendwas veröffentlichen, sondern alles vorher getestet haben. Ist aber – ebenfalls typisch – nicht so. Und so ist es eigentlich wenig überraschend, dass nach Upgrade der alte Grafikkartentreiber (fglrx) nicht mehr läuft. Es gibt aber einen OpenSource-Treiber von ATI, der zwar nicht ganz so toll ist, aber wenigstens läuft – inkl. 3D-Beschleunigung. Leider funktioniert die Anleitung bei UbuntuUsers im Gegensatz zum Treiber nicht.

Lösung

Als erstes muss der richtige Treiber runtergeladen werden. Das geht wie beschrieben auf der ATI-Support-Seite. Anschließend musste ich allerdings erstmal alte Treiberreste entfernen:

sudo apt-get purge fglrx-*

Erst anschließend kann dann der neue Treiber installiert werden. Allerdings nicht mit dem Code aus der Anleitung, der führt zu Fehlermeldungen. Der letzte Teil muss weggelassen werden, die Infos holt sich das Script selber. Dafür aber mit sudo. Also einfach:

sudo sh ati-driver-installer-10-4-x86.x86_64.run

(Der Dateiname muss natürlich ggf. angepasst werden.) Nach kurzer Zeit startet ein Wizard, der zwar keinen Schönheitspreis kriegt, aber schnell und einfach durch die Installation führt. Anschließend einmal rebooten und voilá: Es läuft. Compiz muss zwar neu eingestellt werden, aber das ist verschmerzbar. Hoffentlich hilft das/funktioniert das bei euch.

4 Kommentare to “Ubuntu Lucid Lynx und fglrx”

  1.  Marc schrieb am 06. Mai 2010 um 19:49 zitieren

    Ich hatte nach dem Update von 9.10 auf 10.04 keine solchen Probleme. Obwohl ich auch zugegebenermaßen nicht den ATI-Treiber benutzte. Und aktuell sehe ich auch keinen Grund dafür. Oder kann der etwas Besonderes? Bislang habe ich nur ein hässliches Catalyst gesehen und ansonsten keinerlei Verbesserungen?!

  2.  Mike® schrieb am 07. Mai 2010 um 3:18 zitieren

    Ich bin egtl. ganz zufrieden damit. Gut, passt nicht wirklich zu Deinem Thema, da ich auf 3D-Wackelgeschichten gut verzichten kann, aber bzgl. der Ati-geschichte: was ich derbst dufte finde, dass ich keinen 100MB-Treiber mehr benötige um 2 Monitore anzusteuern. (das ging bisher bei meiner Hardware nicht, bzw. nur extrem umständlich)
    Wo ich grad so schon halb OffTopic bin, wie bescheuert muss man egtl. sein, die Schliessen/etc-Buttons nach Links zu packen?
    Hätte da nicht ein Extra-Modus für die gewöhnlich unterbeschäftigten Mausschieber aus der Apple-fraktion gereicht?

  3.  Greg schrieb am 10. Mai 2010 um 16:26 zitieren

    Zur Verschiebung der Buttons: Wechsel einfach das Theme. Bei mir sind die Buttons rechts. Mark Shuttleworth meinte mal, Mac OSX müsse der Usability-Maßstab für Ubuntu sein. Sehe ich aber auch anders.

  4.  Mike® schrieb am 11. Mai 2010 um 17:07 zitieren

    Theme-wechsel hat mir nicht geholfen, die Buttons waren generell links. Hab das dann über irgendeine Conf geändert, das Netz ist voll davon 😉

    Btw: Auf ’nem anderen Rechner habe ich mich übrigens ins kalte Wasser gestürzt zu versuchen ein 8.04 nach 10.04 zu updaten (online). Das is so gehörig schief gegangen, dass grad garnix mehr geht. Mal bei Gelegenheit schauen, ob ich das von CD repariert bekomme. Kann ich vorerst nur jedem abraten, das zu machen. Zumindest bei der x64-Version. Wie sich das bei der x86-Version verhält weiss ich nicht.

Trackback-Adresse | RSS-Feed für die Kommentare abonnieren

Hinterlasse einen Kommentar:


(Wir behalten uns vor Kommentare von dummen Menschen entweder zu löschen oder exemplarisch für die Nachwelt zu konservieren. Dumme Kommentare mit Werbelinks müssen leider auf zweiteres Privileg verzichten.)

XHTML: Du kannst diese Tags verwenden:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>